Back to overview
Maintenance
Store Temporarily Closed
Apr 18, 2026 at 10:46pm UTC
–
May 7, 2026 at 12:46am UTC
Affected services
store.nexaworldgames.nl
Resolved
May 7, 2026 at 12:46am UTC
Maintenance ended
Affected services
Created
Apr 18, 2026 at 10:46pm UTC
The NexaWorldGames store is temporarily closed until approximately May 7th.
This is due to internal business adjustments to ensure everything is fully compliant with our registration. We are taking this step to prevent any potential issues while we finalize these changes.
All existing services remain active and unaffected. Support is still available during this period.
We appreciate your patience and understanding.
Affected services